频道栏目
IT货架 > > 正文
Android实习札记(3)---Fragment用app包还是v4包解析
网友分享于:Jan 1, 1970 8:00:00 AM    来源: IT货架   

标签:android   style   blog   http   io   color   os   使用   sp   

Android实习札记(3)---Fragment用app包还是v4包解析



1)问题简述

相信很多的朋友在调用Fragment都会遇到下面的情况:


这个时候问题来了...偷笑

到底是用android.app下的Fragment还是用的android.support.v4.app包下的Fragment?



答:其实都可以,没错,都可以!!!我们都知道Fragment是3.0(API 11)后引入的

那么如果开发的app需要在3.0以下的版本运行呢?比如还有一点点市场份额的2.3!

于是乎,v4包就这样应运而生了,而最低可以兼容到1.6版本!

至于使用哪个包看你的需求了,现在3.0下手机市场份额其实已经不多了,随街都是

4.0以上的,所以这个时候,你可以直接使用app包下的Fragment,然后调用相关的方法

通常都是不会有什么问题的;如果你Fragment用了app包的,FragmentManager和FragmentTransaction

都需要是app包的


要么用全部用app,要么全部用v4,不然可是会报错的哦!

当然如果你要自己的app对于低版本的手机也兼容的话,那么就可以选择用v4包

但是使用v4包很多要注意的地方!



2)使用v4包要注意的事项:


①如果你使用了v4包下的Fragment,那么所在的那个Activity就要继承FragmentActivity哦!

案例:今天在xml文件中静态地载入fragment,然后重写了Fragment,但是在加载Activity的时候就报错了,

大概的提示就是Fragment错误还是找不到什么的,name属性改了几次还是错!最后才发现是用了

v4的包的缘故,只需让自己的Activity改成FragmentActivity即可!



②今天写这句代码的时候竟然用不了,错误情况如下:


有点莫名其妙啊,Fragment,FragmentManager,FragmentTransaction都是用的v4包啊,

Activity也是继承FragmentActivity的啊?都改成app包就可以了,但是这不和我们用v4包的

前提冲突了么?其实也是有解决方法的哈?

答:只需要把getFragmentManager( )改成 getSupportFragmentManager( )就可以了

Android实习札记(3)---Fragment用app包还是v4包解析

标签:android   style   blog   http   io   color   os   使用   sp   

广告服务联系QQ:1134687142 | 网站地图

版权所有: IT货架- 内容来自互联网,仅供用于技术学习,请遵循相关法律法规. 京ICP备11030978号-1