频道栏目
IT货架 > > 正文
aptitude解决Ubuntu各种依赖问题
网友分享于:Jun 12, 2018 11:47:54 PM    来源: IT货架   

转自:http://allog.ml/linux/aptitude%E8%A7%A3%E5%86%B3ubuntu%E5%90%84%E7%A7%8D%E4%BE%9D%E8%B5%96%E9%97%AE%E9%A2%98/

 

 

完成
正在分析软件包的依赖关系树
正在读取状态信息… 完成
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
gcc : 依赖: gcc-4.8 (>= 4.8.1-4~) 但是它将不会被安装
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。

或:

sudo apt-get install build-essential
正在读取软件包列表… 完成
正在分析软件包的依赖关系树
正在读取状态信息… 完成
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
build-essential : 依赖: gcc (>= 4:4.4.3) 但是它将不会被安装
依赖: g++ (>= 4:4.4.3) 但是它将不会被安装
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。

遇到类似的依赖,可以用aptitude命令来解决,aptitude本来是debian的默认软件,但是最近几个版本的ubuntu里面好像没有这个工具了。那就自己安装一个吧。

不管三七二十一,更新先:

sudo apt-get update && sudo apt-get dist-upgrade

然后安装今天的主角:

然后用aptitude替代apt-get来安装软件。

sudo aptitude install build-essential

 


广告服务联系QQ:1134687142 | 网站地图

版权所有: IT货架- 内容来自互联网,仅供用于技术学习,请遵循相关法律法规. 京ICP备11030978号-1