频道栏目
IT货架 > > 正文
AndroidManifest.xml的<uses-sdk>节点
网友分享于:Jun 12, 2018 11:44:31 PM    来源: IT货架   

<uses-sdk>
用于告知系统应用使用的Android SDK兼容范围。

语法:

 

属性:

android:minSdkVersion
应用兼容到最小的SDK版本,如果值大于用户手机系统的版本,将不能安装。如果不指定该值,则默认为1。实际写代码中,要兼容的版本越小,程序中需要处理的版本兼容问题就越多

 

android:targetSdkVersion
应用最佳运行SDK版本。如果缺省,默认等于minSdkVersion。如果运行系统版本高于targetSdkVersion,系统会想办法向下兼容,使用一些老版本的特性。总而言之,如果targetSdkVersion大于系统版本,则由应用负责处理版本兼容;如果targetSdkVersion小于系统版本,则由系统负责处理版本兼容。

 

android:maxSdkVersion
应用最高兼容的SDK版本。实际一般没什么作用,用为Android都是兼容老应用的,所以不用填。


广告服务联系QQ:1134687142 | 网站地图

版权所有: IT货架- 内容来自互联网,仅供用于技术学习,请遵循相关法律法规. 京ICP备11030978号-1