频道栏目
IT货架 > > 正文
MacOS 10.8.5装配JDK1.7后,软件无法启动,提示需要java1.6.+的兼容版本
网友分享于:Jun 12, 2018 10:42:06 PM    来源: IT货架   
MacOS 10.8.5安装JDK1.7后,软件无法启动,提示需要java1.6.+的兼容版本

版权所有,转载请注明来源http://gogo1217.iteye.com,违者必究!

 

之前提到过Mac OS 10.8.3移除了自带的JDK1.6,安装了Oracle的1.7后,eclipse找启动提示需要JRE环境的解决办法,详见:点击我。

 

这几天在看看docbook,安装了Oxygen XML Editor。启动后,总是提示找不到Java1.6+兼容的版本,但是通过终端启动sh可以启动(执行./oxygenDeveloperMac.sh),和eclipse提示JRE的情况很相似,命令行启动都没问题,但是GUI的方式都报java版本未找到的错误提示。

 

在经过多次GOOGLE后的实验,最终的在http://www.olarila.com/forum/viewtopic.php?f=28&t=2961&view=next 找到了解决办法,通过软连接的方式创建丢失时的文件以及注册丢失的信息,即可让软件识别Java7。

具体操作如下(下文的操作已经根据我本地的Java版本进行修改,我的版本为1.7.0_40):

$ cd /Library/Java/JavaVirtualMachines/jdk1.7.0_40.jdk/Contents/Home/
$ sudo ln -s ../ bundle
$ cd bundle
$ sudo mkdir Libraries
$ cd Libraries
$ sudo ln -s ../Home/jre/lib/server/libjvm.dylib libserver.dylib
$ sudo /usr/libexec/PlistBuddy -c "Add :JavaVM:JVMCapabilities:1 string JNI" /Library/Java/JavaVirtualMachines/jdk1.7.0_40.jdk/Contents/Info.plist
$ sudo /usr/libexec/PlistBuddy -c "Add :JavaVM:JVMCapabilities:2 string BundledApp" /Library/Java/JavaVirtualMachines/jdk1.7.0_40.jdk/Contents/Info.plist 

 

广告服务联系QQ:1134687142 | 网站地图

版权所有: IT货架- 内容来自互联网,仅供用于技术学习,请遵循相关法律法规. 京ICP备11030978号-1